Red Hat, Centos, Fedora e Rhel Based com intel E1000 (e1000e) apresentando queda de rede

Standard

Uma coisa interessante, na verdade um bug no módulo de rede E1000 (Intel GB) está ocorrendo em plataformas Rhel Based (Red Hat 5.x e 6.x e Fedora 16) onde o sistema operacional simplesmente deixa a interface de rede trabalhando, do nada a mesma apresenta congelamento (isto mesmo, o sistema continua on, mas a interface de rede OFF). Não adiantará muito atualizar o Kernel, pois ele não trará a solução. Abaixo irei dar dicas de como resolver, no meu caso fui vitimado sob Centos 6.2:

Como root execute:

lsmod | grep e1000

Se a resposta for:

e1000e

Execute o comando como root:

modinfo e1000e

Na saída, logo no começo, veja se a informação do módulo é esta:

version: 1.4.4-k

Caso seja é JUSTAMENTE a cabrita bugada, para sanar vamos ativar um repositório com rpms fresquinhos:

CentOS 6.x -> rode como root:

rpm -Uvh http://elrepo.org/elrepo-release-6-4.el6.elrepo.noarch.rpm

CentOS 5.x -> rode como root:

rpm -Uvh http://elrepo.org/elrepo-release-5-3.el5.elrepo.noarch.rpm

Depois, como root rode:

yum install kmod-e1000e.x86_64 -y

Depois será necessário um reboot no servidor.
Assim que o servidor levantar rode:

modinfo e1000e

Veja se está como abaixo:

[root@appunixlabs ~]# modinfo e1000e
filename: /lib/modules/2.6.32-220.17.1.el6.x86_64/weak-updates/e1000e/e1000e.ko
version: 1.11.3-NAPI

 

Devemos forçar o kernel a utilizar alguns recursos a menos para que possamos contornar o bug, vamos forçar o consumo de energia ao invés de poupar (infelizmente TI verde não é com essa NIC -> Active-State Power Management tem de estar OFF), entre no grub.conf e informa a linha abaixo no final da instrução de boot do kernel utilizado por seu sistema:

pcie_aspm=off e1000e.IntMode=1,1 e1000e.InterruptThrottleRate=10000,10000 acpi=off

 

Se você receber Kernel Panic por causa das flags acima, entre novamente no servidor com qualquer outra imagem de kernel e informe no final da primeira instrução de kernel que apresentava Kernel Panic:

pcie_aspm=off

Somente a flag acima e deixa o pau quebrar.

 

Bug informado em:

https://bugzilla.redhat.com/show_bug.cgi?id=632650

https://bugzilla.redhat.com/show_bug.cgi?id=808638

https://bugzilla.redhat.com/show_bug.cgi?id=625776

http://bugs.centos.org/view.php?id=5614

 

Problemas com drive intel 82801 GB ICH7- como instalar corretamente

Standard

Pessoal, sei que existem técnicos maravilhosos em nosso meio, por isso decidi somente complementar algo aqui. (isso é para windows XP 32 bits)

Percebi que a pcchips dá suporte a uma placa intel com socket 775, em outras palavras, que exigia a instalação de um drive chamado Intel 82801GB ICH7 HIGH DEFINITION AUDIO.

Bem, sem mais demoras eu vou deixar o link disponível para baixar o drive e logo em seguida explico como sanar:

http://www.libphp.net/Intel_82801GB_ICH7.rar

Pegue este arquivo, abra-o com o Winrar (ou ferramenta de compactação que suporte .RAR).

Assim que isto for feito não instale de imediato, procure percorrer os diretórios e localize um KB (aquele que faz o High Definition Audio Rodar e requerer drive para o som, entretanto este é o melhor) chamado KB35221, este carinha será responsável por abrir os caminhos.

Assim que terminar a instalação do mesmo abra o setup e instale.

Caso funcione EU quero uma CAIXA de BIS, ok? (pode ser chocolate branco também)… rsrsrs

Abraços a todos e fiquem com Deus.