Como instalar Adobe Air (latest) 2.5.x no seu Fedora 14 (64 bits) x86_64 e tweetdeck

Standard

Olá pessoALL,

Há muito tempo estive a procura de instalar o adobe air e TweetDeck junto ao meu Fedora 14 (x86_64) 64 bits.

Serei bastante breve no que tange a instruções, que na verdade vou postar o que tive de fazer para colocar o sistema para funcionar, abaixo seguem a lista de todos os comandos que usei, entratanto no fim entendi que o erro resumia-se na condição de instalar toda arquitetura de pacotes 32 bits para poder operar o adobeair de maneira eficaz, assim como poder instalar o TweetDeck.

Primero logue-se como root, siga os comandos:

Como instalar o adobe air no fedora 14.

Primeiros comandos:

$ sudo yum install ld-linux.so.2
$ sudo yum install gtk2-devel.i586
$ sudo yum install libdbus-glib-1.so.2
$ sudo yum install libhal.so.1
$ sudo yum install rpm-devel.i586
$ sudo yum install libXt.so.6
$ sudo yum install gnome-keyring-devel.i586
$ sudo yum install libDCOP.so.4

$ sudo yum install libxml2-devel.i586
$ sudo yum install nss-devel.i586
[root@developer Downloads]# rpm -Uhv http://download.fedora.redhat.com/pub/fedora/linux/releases/14/Everything/source/SRPMS/libXcomposite-0.4.2-1.fc14.src.rpm
Obtendo http://download.fedora.redhat.com/pub/fedora/linux/releases/14/Everything/source/SRPMS/libXcomposite-0.4.2-1.fc14.src.rpm
1:libXcomposite ########################################### [100%]
[root@developer Downloads]# rpm -Uhv http://download.fedora.redhat.com/pub/fedora/linux/releases/14/Everything/source/SRPMS/libatk1.0.so.0^C
[root@developer Downloads]# rpm -Uhv http://rpm.pbone.net/index.php3/stat/3/srodzaj/2/search/libatk1.0_0-1.9.0-0.2.mdk10.1.thac.ia64.rpm^C
[root@developer Downloads]# rpm -Uhv http://hany.sk/mirror/fedora/releases/14/Everything/source/SRPMS/atk-1.30.0-5.fc14.src.rpm
Obtendo http://hany.sk/mirror/fedora/releases/14/Everything/source/SRPMS/atk-1.30.0-5.fc14.src.rpm
1:atk ########################################### [100%]
[root@developer Downloads]# rpm -Uhv http://hany.sk/mirror/fedora/releases/13/Everything/source/SRPMS/gtk2-2.20.1-1.fc13.src.rpm
Obtendo http://hany.sk/mirror/fedora/releases/13/Everything/source/SRPMS/gtk2-2.20.1-1.fc13.src.rpm

[developer@developer Downloads]$ rpm -Uhv gtk2-2.22.0-1.fc14.1.src.rpm
1:gtk2 ########################################### [100%]
[developer@developer Downloads]$

[root@developer Downloads]# rpm -Uhv http://download.fedora.redhat.com/pub/fedora/linux/releases/14/Everything/source/SRPMS/libXcomposite-0.4.2-1.fc14.src.rpm
Obtendo http://download.fedora.redhat.com/pub/fedora/linux/releases/14/Everything/source/SRPMS/libXcomposite-0.4.2-1.fc14.src.rpm
1:libXcomposite ########################################### [100%]
[root@developer Downloads]# rpm -Uhv http://download.fedora.redhat.com/pub/fedora/linux/releases/14/Everything/source/SRPMS/libatk1.0.so.0^C
[root@developer Downloads]# rpm -Uhv http://rpm.pbone.net/index.php3/stat/3/srodzaj/2/search/libatk1.0_0-1.9.0-0.2.mdk10.1.thac.ia64.rpm
Obtendo http://rpm.pbone.net/index.php3/stat/3/srodzaj/2/search/libatk1.0_0-1.9.0-0.2.mdk10.1.thac.ia64.rpm
erro: /var/tmp/rpm-tmp.v9dm3k: não é um pacote rpm (ou um manifesto de pacote):
[root@developer Downloads]# rpm -Uhv http://rpm.pbone.net/index.php3/stat/3/srodzaj/2/search/libatk1.0_0-1.9.0-0.2.mdk10.1.thac.ia64.rpm^C
[root@developer Downloads]# rpm -Uhv http://hany.sk/mirror/fedora/releases/14/Everything/source/SRPMS/atk-1.30.0-5.fc14.src.rpm
Obtendo http://hany.sk/mirror/fedora/releases/14/Everything/source/SRPMS/atk-1.30.0-5.fc14.src.rpm
1:atk ########################################### [100%]
[root@developer Downloads]# rpm -Uhv http://hany.sk/mirror/fedora/releases/14/Everything/source/SRPMS/gtk2-2.22.0-1.fc14.1.src.rpm
Obtendo http://hany.sk/mirror/fedora/releases/14/Everything/source/SRPMS/gtk2-2.22.0-1.fc14.1.src.rpm
1:gtk2 ########################################### [100%]
[root@developer Downloads]#

yum install libxml -y
yum install libstdc++.so.5 -y

[root@developer Downloads]# yum install gtk2.i686 -y

yum install libcanberra-gtk2.i686 PackageKit-gtk-module.i686 -y

yum install libxslt libxslt-devel mingw32-libxslt-static.noarch libxslt-debuginfo.x86_64 perl-XML-LibXSLT.x86_64 -y

yum install gtk-murrine-engine.x86_64 gtk-murrine-engine-debuginfo.x86_64 gtk-nodoka-engine.x86_64 -y

rpm -ivh adobeair.i386.rpm –ignorearch

yum install ld-linux.so.2 gtk2-devel.i686 libdbus-glib-1.so.2
libhal.so.1 rpm-devel.i686 libXt.so.6 gnome-keyring-devel.i686
libDCOP.so.4 libxml2-devel.i686 nss-devel.i686 libxslt.i686 xterm -y

—-

Percebam que o ponto chave está abaixo, se instalasse os pacotes abaixo como sendo nomedopacote.x86_64 o Fedora iria instalar sem problemas, mas só rodaria se instalasse como i686    :^(

yum install libgnome-keyring.i686 gnome-keyring-pam.i686 gnome-keyring.i686 gnome-keyring-devel.i686 gnome-keyring-sharp.i686 gnome-keyring-debuginfo.i686 gnome-keyring-sharp-devel.i686 gsql.i686 -y

Depois acesse o site da Adobe e baixe o binário de instalação do Adobe Air no site da Adobe, como root dê um ./nome_do_binário.bin, a foto abaixo mostra a execução (ela foi tirada antes do último comando YUM acima que fizemos, por isso requeria as dependências posteriormente instaladas, não se PREOCUPE com o erro da foto, as dependências do último comando YUM sanarão tudinho para você):

Depois disto acesse o site do TweetDeck e instale-o.

Veja a foto da instalação sem problemas (assim que o adobe air estiver instalado, depois de todos os comandos YUM citados rode o instalador do tweetdeck no site, o sistema irá pedir autorização de root para ativar o tweetdeck no container adobe air):

A prova segue abaixo 😛

Fedora 14: como instalar o PidGin de maneira fácil

Standard

Nem considero um artigo, mas uma espécie de “comandos do dia”. Se você é um usuário semelhante a mim, gosta muito do pidgin e sentiu falta do danado em seu Fedora 14, no problem, basta fazer o seguinte:

1 – clique em Aplicativos, depois clique em Sistema e por fim escolha TERMINAL.

2 – digite su – para que você solicite permissão de root com todos os recursos globais de root.

3 – digite yum install pidgin -y

Feito isto o próprio YUM (gestor de pacotes muito eficaz e automatizado do Fedora/Centos/Rhel — Red Hat Based) fará todo o trabalho sujo para nós :P.

Depois disto é só alegria.

O pidgin estará no menu:

Iniciar –> Internet –> “Mensageiro de Internet Pidgin”.